• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

B44 / B44.1 / B44.2 pictures and videos thread

Bubba Boggs

Well-Known Member
Factory Member
Joined
Sep 25, 2012
Likes
280
Location
Floris Iowa
#2
2012-11-09 05 03 11.JPG
2012-11-09 05 02 19.JPG



Just took a couple after the complete rebuild
 

Bubba Boggs

Well-Known Member
Factory Member
Joined
Sep 25, 2012
Likes
280
Location
Floris Iowa
#8
Nope still running the 44.1... The new kit will be for the Reedy Race.
 
Joined
Jun 5, 2012
Likes
4
Location
Chicago
#10
B44.1 with some .2 updates...







This is an old pic and the only body-off I have, it's before big bores, .2 towers and LRP flow.
 
Joined
Jun 5, 2012
Likes
4
Location
Chicago
#13
Thanks.

Very happy with the new LRP Flow, I run them in both my buggies. I had no complaints with old SXX V2 esc's as well.
 

Martijn

Well-Known Member
Joined
Jun 4, 2012
Likes
214
Location
Oudenaarde/Belgium
#15
Thanks.

Very happy with the new LRP Flow, I run them in both my buggies. I had no complaints with old SXX V2 esc's as well.
Lucky you ;)

I destroyed my a week to go at the race, pluged the battery in and de sxx did nothing.. no lights..

I needed a esc for my presentation yesterday about my finalpaper, my friend had bought one 4days ago (secondhand) soldered new wires etc like he asked. Ran 3 straight lines at school... again nothing..

I did got a blinking action of the esc, yellow and blue, means that the esc got too hot.. ? Just by driving 3 straight lines...??
This really sucks now :p

So yeah, my new LRP flow is just shipped I hope that one doesn't fail on me..
 

Hector.

Well-Known Member
Joined
Jan 29, 2013
Likes
107
Location
North Dakota, Bismarck
#16
Sounds like you have a motor or some other problem.

Be careful or you will wreck another ESC.

Bad bearing in motor, seized up, CVD hanging, even a bad servo can cause heat issues.
Bad battery or receiver, motor wired wrong?
 

Martijn

Well-Known Member
Joined
Jun 4, 2012
Likes
214
Location
Oudenaarde/Belgium
#18
Sounds like you have a motor or some other problem.

Be careful or you will wreck another ESC.

Bad bearing in motor, seized up, CVD hanging, even a bad servo can cause heat issues.
Bad battery or receiver, motor wired wrong?
Motor, hmm.. should be fine.
Checked the bearings and grease em.
Bad servo, got the ds1015 pretty good servo never got problems..

Motor wired good, reedy battery, spektrum receiver.
 

Latest posts

Forum statistics

Threads
4,959
Messages
50,237
Members
3,177
Latest member
Screwie louie